Java Eclipse Download For Mac

  1. Eclipse Oxygen Download For Java Mac
  2. Eclipse Ide For Java Developers Download For Mac
  3. Java Ee Eclipse Download For Mac

In CS106A, we'll be using Stanford's customized version of Eclipse to build our programs. Eclipse is an enormously popular industrial-strength Java environment with many features. Fortunately, Eclipse is also open source -- anyone is free to change Eclipse to work the way they want. We have taken advantage of that freedom to install special Stanford features into Eclipse, tailoring it specifically for CS106A. This document gives instructions on how to get started using Stanford Eclipse. Please pay close attention to these instructions and do not skip steps!

Contents

We recomend downloading Eclipse IDE for Java EE Developers for Windows or Mac OS X. Then follow the installation instructions. Download plugin: Windows; Mac OS X; Unzip into eclipse installation directory; There should be new files in ECLIPSEROOT/plugins and ECLIPSEROOT/features; Run Eclipse; Hello World. Download the latest version of Eclipse IDE for Java EE Developers for Mac. Integrated development environment for Java and other languages. Eclipse IDE for. No problem, you can download the full installer below, which includes Eclipse 3.7, BlackBerry Plug-in for Eclipse 2.0.0 and the BlackBerry 7.1 SDK conveniently packaged in a single installer. Please note that BlackBerry simulators are currently not available for Mac OS.

Mac Installation Windows Installation Configuring Eclipse for CS106A I need help!

Installing Eclipse on a Mac

Stanford Eclipse will only work on Mac OS X version 10.6 or higher. If you don't have that version of the operating system, you'll need to either upgrade or do your class work in a public cluster.

  1. Download and install the Java SDK installer for Mac
  2. Download the Mac version of Eclipse
  3. Double-click on the file eclipse-mac.dmg to open the Eclipse disk image(You can delete eclipse-mac.dmg afterwards).
  4. Drag the Eclipse app into the Applications folder on your Mac.
  5. Drag the Eclipse icon from your Applications folder to your Dock to create a shortcut.
  6. Click on the icon in the dock to open Eclipse. If you see an error that says Eclipse 'can't be opened because it is from an unidentified developer,' right-click on the Eclipse icon and select 'open' instead. You will be able to open Eclipse without right-clicking from now on.
  7. Skip to the instructions below to configure Eclipse for CS106A.

Installing Eclipse in Windows

Java

Our version of Eclipse will run on Windows 7 (2009) or higher. In the very unlikely event you have an older version of Windows on your computer, you will need to either upgrade or do your class work in one of the public computer clusters. You can check your version of Windows using these instructions.

Eclipse Oxygen Download For Java Mac

  1. Uninstall previous versions of the Java Runtime Environment (JRE). Before installing a new version of the JRE, we recommend that you remove any older copies that may be installed on your system.
    • If you have Windows 7 or 8, do the following: Click on Start, then click on Control Panel, then select Programs and Features.

      If you have Windows 10, do the following: Click on Start (the Windows icon in the lower left-hand corner), then click on Settings (the gear-shaped icon), then select Apps & Features.

    • From the list of programs you see, uninstall any occurrences of Java/J2SE Runtime Environment, Java SDK, Java SE Development Kit or Java Update. Note that the exact program name may be slightly different or include a version number, but you generally want to remove anything that includes the text: Java/J2SE Runtime Environment, Java SDK, Java SE Development Kit or Java Update. To remove a program, click on the program name to highlight it and click the the Uninstall button.
  2. Download Eclipse.
    Save the downloaded file to somewhere on your hard drive. This may take a little while as the file is rather large.
  3. Unzip/extract the contents of the file by right-clicking on the folder you just downloaded, selecting the Extract All.. option and typing C:Program Files as the location to extract the files to. Then continue following the steps in the extraction process.
  4. Create a shortcut to Eclipse on your Desktop for easy access — Open the C:Program Fileseclipse directory, and right-click and drag the eclipse.exe file (the Eclipse application) to your desktop and then select the option Create shortcut here.
  5. Note: If you installed the 64 bit versions of the software, and find that you have issues running Eclipse, we recommend that you uninstall Eclipse by deleting the C:Program Fileseclipse directory and install the 32 bit versions of both: the JRE 32 bit version for Windows and Eclipse 32 bit version for Windows, in that order.

  6. Continue to the instructions below to configure Eclipse for CS106A.

Eclipse Ide For Java Developers Download For Mac

Configuring Eclipse for CS106A (both Mac and Windows)

Java Ee Eclipse Download For Mac

Once you have Eclipse installed on your computer, there are a few CS106A-specific changes you need to make so that you can access some special Stanford features, like submitting assignments. The following instructions apply to all operating systems, although the screenshots are from a Mac. Framework 3.5 full package offline.

  1. Open Eclipse if you haven't already. When you run Eclipse for the first time, you may get a screen that looks like this:
    A workspace is just a directory that Eclipse will use to place new projects in. In 106A you won't have to make any new projects from scratch. We will always give you skeleton projects for your assignments, so you don't need to worry about where the workspace is. The suggested location is fine. Click the Use this as the default and do not ask again checkbox, and then click OK.
  2. Once Eclipse has started, you can close the 'Welcome' tab using the 'X' in the top left.
  3. Click Help -> Install New Software.
  4. In the 'Work with' text box, type https://web.stanford.edu/dept/cs_edu/eclipse/plugin and press Enter.
  5. Click 'Select All,' then click Next.
  6. Click Next again.
  7. Click 'I accept the terms of the license agreement,' then click Finish.
  8. Click OK when you see the warning about installing unsigned content.
  9. Click Yes when asked to restart Eclipse.
  10. After restarting, you should see a 'Stanford Menu' in the top bar, as well as several new icons in your top toolbar area.
  11. Go to Eclipse -> Preferences to open the Preferences window. In the dropdowns on the left, expand Run/Debug, and click Perspectives. Set 'Open the associated perspective when an application suspends' to Never, as shown below, and click Apply and Close.
  12. Now that you have Eclipse loaded and configured, your next step is to add a project to your workspace by importing a skeletal framework that we provide with each assignment called a starter project. Using starter projects makes your life much easier by allowing you to ignore the many details involved in creating a project from scratch. Every assignment will include a starter project for each problem, and your first task for each assignment will be to download the starter project from the class website and then import it into your workspace. The details for doing so are described in the handout 'Using Karel with Eclipse'.

Having trouble with your installation?

Check out this doc for common Eclipse errors and issues / Troubleshooting, email the Head TA or stop by their Office Hours, or stop by the LaIR. During the first week, you can also stop by the Eclipse Setup Session on Wednesday 4/4/18 7-9 PM in the LaIR (first floor of Tresidder).

Java Eclipse Download For Mac

Troubleshooting

  • Q: Eclipse is showing an error in the Console 'Could not save C++ lib configuration file.' Do I need to worry about this?
    A: No. This error should not affect the running of your programs, and you can ignore it.

  • Q: Help! I don't see the 'running person', submit, import, etc. icons or the 'Stanford Menu' in my Eclipse.
    A: This means the Stanford Plugin is not installed; please repeat the steps under 'Installing the CS106A plugin' above.

  • Q: My Eclipse window doesn't look like the ones in the screenshots or in lecture. I'm missing some of the panels (e.g. the sidebar showing all my projects). Help!
    A: Click the 'Reset' button in the Stanford Menu to reset to the default view. You may also be in Debugger mode instead of Editor mode; use the Stanford Menu to go back to Editor mode.

  • Q: Eclipse is not letting me import a project. It gives me a warning at the top of the import window that 'Some projects cannot be imported'.
    A: This is because a project with that name is already imported into Eclipse. If you would like to import this project, you must first delete the existing project by right-clicking the project in the sidebar and selecting 'Delete'. You can then choose whether to delete the project from your computer as well, or just delete the project from Eclipse.

  • Q: When I run a Karel program, it immediately crashes with an 'Unsupported Version Error'.
    A: This means Eclipse is using Java 9, which is not compatible with running your programs. See the solution to the following question about being unable to run programs.
  • Q: When I click the running person icon to run programs, Eclipse gives me an error that it 'could not find any programs to run', even though I have a project imported with programs.
    A: This means Eclipse is using Java 9, which is not compatible with running your programs. To change Eclipse to use Java 8 instead, follow these steps:
    1. Open Eclipse Preferences: On Mac: in the top toolbar, go to Eclipse -> Preferences. On Windows: in the top toolbar, go to Window -> Preferences.
    2. Change JRE version to 8: In the sidebar of the preferences window, expand the 'Java' section. Click on 'Installed JREs'. If the checked option is a version of Java SE 9, instead check the box next to Java SE 8 [1.8.0_152]. Click 'Apply' in the bottom right.
    3. Change Compiler version to 1.8: In the sidebar of the preferences window, click on 'Compiler'. If the 'Compiler compliance level' is 9, change it to 1.8. Click 'Apply' in the bottom right.
    4. Close the preferences window. You should be good to go!