Sccm Deployment Waiting For Another Program

This is just a quick post to help those who are struggling to find the correct syntax to place into the program (CMD line) field when deploying a PowerShell Script as an application or program for that matter using SCCM.

I have a problem with my sccm server. The version of software is SCCM RTM I have create a package for deploy a flash Player.msi. The problem is that when I'm going to do the Deploy monitor on all computers, I'm in the following state: Waiting for Content 'I'm getting crazy help me?? ConfigMgr sccm patching status based collections. LastEnforcementMessageID LastEnforcementMessageName. 1 Enforcement started. 3 Waiting for another installation to complete. 6 General failure. 8 Installing update. 9 Pending system restart. 10 Successfully installed update. 11 Failed to install update. Users report that expected Software applications are not being installed. Reports show Advertisements in a “Waiting” state, seemingly indefinite. Distribution Points seem to be taking too long to replicate or update content; Potential Causes ^ Package or Deployment content has not been copied to the required Distribution Point (DP) servers.

For an “Application” “Deployment type” just place this into the Program line.

Application Deployment Type - Program

Sccm Deployment Waiting For Another Program May

'%Windir%sysnativeWindowsPowerShellv1.0powershell.exe'-ExecutionPolicy Bypass-Command.Your-Scriptfilename.ps1

Sccm Deployment Waiting For Another Program For Windows 7

Note: When using MDT install applications step in you task sequence (Customsettings or MDT DB driven) to install programs this also works a treat!

Sccm Deployment Waiting For Another Program For Business

You can add other properties also like -NoProfile but to be honest I have found this to work 100% of the time without the need for those extras. Just make sure you detection method is solid!

Autodesk download autocad mac

Sccm Deployment Types

Installing the software through software center gives error code 0x87D00324(-2016410844) although installation is successful.
Running the same msi manually from same location works without any error.
AppEnforce.log shows below:
Prepared command line: 'C:WINDOWSsystem32msiexec.exe' /x 'GlobalProtect64.msi' /q AppEnforce 8/7/2019 11:53:29 AM 12076 (0x2F2C)
Executing Command line: 'C:WINDOWSsystem32msiexec.exe' /x 'GlobalProtect64.msi' /q with user context AppEnforce 8/7/2019 11:53:29 AM 12076 (0x2F2C)
Working directory C:WINDOWSccmcached AppEnforce 8/7/2019 11:53:29 AM 12076 (0x2F2C)
Post install behavior is BasedOnExitCode AppEnforce 8/7/2019 11:53:29 AM 12076 (0x2F2C)
Waiting for process 11928 to finish. Timeout = 120 minutes. AppEnforce 8/7/2019 11:53:29 AM 12076 (0x2F2C)
Process 11928 terminated with exitcode: 1605 AppEnforce 8/7/2019 11:53:30 AM 12076 (0x2F2C)
Looking for exit code 1605 in exit codes table.. AppEnforce 8/7/2019 11:53:30 AM 12076 (0x2F2C)
Unmatched exit code (1605) is considered an execution failure. AppEnforce 8/7/2019 11:53:30 AM 12076 (0x2F2C)
Any ideas?